Friday, February 28, 2014

Framework 4.5.1 and SQL Server Issue

I knew this day would come….

 

We have a virtual machine that is still running an non-upgradeable legacy system with a SQL Server 7.0 database backend – and it can’t be upgraded!

 

Microsoft decided to publish the .NET Framework 4.5.1 as an important/forced update.  Which broke the code to connect to the legacy system using the System.Data.SqlClient.Connection classes.

 

The only real fix for this is the connect to the system is by using the System.Data.OLEDB classes.  It works – a little slower, but works.

 

Thanks again Microsoft!

 

No comments: